Статьи

Какой нужен хостинг для WordPress?

Сразу оговорюсь, что для WordPress подходит любой хостинг, поддерживающий php. Если буквально перевести, к примеру, требования последней на момент написания этой статьи версии движка (4.2.2.) то необходимы:

  • PHP версии 5.2.4. или выше;
  • MySql версии 5.0 или выше.

Как видим, ничего сложного. На практике, вы можете обнаружить, что этот движок довольно медленно работает при недостатке ресурсов и минимальные тарифы, которые предоставляют хостинги, для него не вполне достаточны даже при минимальной посещаемости.

Здесь два пути выхода из ситуации:

  1. Переход на другой, более ресурсообеспеченный тариф;
  2. Снижение нагрузки на сайт за счет различных настроек и оптимизации движка.

Первый путь понятен. Здесь надо отметить, что даже недорогой хостинг вполне должен обеспечивать работу сайта с несколькими сотнями посетителей в день.

Что касается оптимизации работы движка то, пожалуй, максимального эффекта здесь можно добиться, установив один из плагинов кэширования. Наиболее популярны из них это Hyper Cache и Super Cache. Вы легко сможете найти их в депозитарии плагинов WordPress. Для сайтов с высокой посещаемостью можно обратить внимание на платные скрипты кэширования, способные снизить нагрузку на сайт в большей степени, чем вышеупомянутые плагины.

Кроме того, серьезную нагрузку на сайт могут создавать разного рода боты и роботы. Некоторые из них, такие как поисковые роботы, полезны для сайта, поскольку обеспечивают его видимость в поисковых системах. Другие, наоборот вредны, как минимум, из-за того, что создают дополнительную нагрузку на сайт. А некоторые боты ищут уязвимости в вашем сайте.

Часть роботов можно закрыть. Более подробную информацию об этом можно найти в интернет. Для защиты от хакеров будет полезна статья Как закрыть файл login.php.

Более подробно по выбору подходящего хостинга для сайта на WordPress читайте на сайте http://delaemsait.info/vybiraem-luchshij-xosting-dlya-sajta-na-wordpress/.

Оставьте Ваш отзыв